Receive from HW not working

  • Creator
    Topic
  • #52678
    Avatarirw
    Participant
    Offline
    Registered On: December 12, 2018
    Topics: 3
    Replies: 6
    Has thanked: 1 time
    Been thanked: 1 time

    Hi Guys,

    Bought the MS2k editor as well, because I really like the MicroQ editor as well.
    The editor works, it can send data, but, can’t get anything from the hardware!

    I’ve tried to import the banks with MIDIQuest, it works!
    But…actually, can’t import the saved sysex to the editor?
    Can’t get my patches :D:D

  • Author
    Replies
  • Avatar
    Novaline
    Moderator
    Offline
    Registered On: October 14, 2016
    Topics: 4
    Replies: 208
    Has thanked: 1 time
    Been thanked: 0 times

    hello,

    are you able to sync data from hardware when you open up the librarian?
    if yes, you should be able to send or get data to your editor and synth.

    if you want to send data to your hardware, do the following.

    open up the librarian and press bank edit and select Request data to get data from the hardware or store data in order to send data to hardware.

    hope this helps, if something else is on your mind. let me know

    thanks
    Mauricio

    STUDIO GEAR: RME FIREFACE 802, ALESIS AI3, EVE AUDIO SC 207, ROLAND JP8000, ROLAND JP8080, NOVATION SUPERNOVA, ACCESS VIRUS A, WALDORF PULSE, ROLAND SH201

    Avatar
    irw
    Participant
    Offline
    Registered On: December 12, 2018
    Topics: 3
    Replies: 6
    Has thanked: 1 time
    Been thanked: 1 time

    Ouch, forgot to turn on the notifications …
    Thanks, I’m able to send data to the synth, complete banks etc., the problem is when I hit request date from HW, nothing happens.
    No single patch receive, no bank receive, can’t even receive the edit buffer from the synth…
    Weird, no error message either on the synth nor the editor.

    Avatar
    JRVms2000
    Participant
    Offline
    Registered On: August 27, 2019
    Topics: 1
    Replies: 3
    Has thanked: 0 times
    Been thanked: 0 times

    Same issue here. Any solution wold be helpful.

    Avatar
    irw
    Participant
    Offline
    Registered On: December 12, 2018
    Topics: 3
    Replies: 6
    Has thanked: 1 time
    Been thanked: 1 time

    Tried to send a whole bank, no luck…
    Saved it to a MIDI file and tried to load it with MidiQuest, it freezed out 🙁

    Avatar
    Novaline
    Moderator
    Offline
    Registered On: October 14, 2016
    Topics: 4
    Replies: 208
    Has thanked: 1 time
    Been thanked: 0 times

    hey guys,
    i tried this myself now with my MS2000R and it seems there is some sort of bug. I cannot transfer any patches to my hardware as well.

    this will be reported to admin to fix for a new update.

    in the meantime, if you got any other solution to send data to hardware, use another midi program to transfer the midi files you want.

    Loading patches to my DAW works fine tho for me.

    Thanks for the report
    Mauricio

    STUDIO GEAR: RME FIREFACE 802, ALESIS AI3, EVE AUDIO SC 207, ROLAND JP8000, ROLAND JP8080, NOVATION SUPERNOVA, ACCESS VIRUS A, WALDORF PULSE, ROLAND SH201

    Avatar
    w4too
    Participant
    Offline
    Registered On: July 22, 2019
    Topics: 1
    Replies: 7
    Has thanked: 1 time
    Been thanked: 0 times

    Hi,

    I just bought the plugin, as i’m already using the NL2xR, but it seems that i also have this problem with data import.
    The only way for me to import HW patch is by using the program selector on the front panel but it’s working very randomly and can be very slow.
    I only can send patches from the library also and the plugin react to the HW knobs manipulation. The sysex transfer from HW looks buggy.

    Everything is working fine with the NL2xR and patch data transmission so i suppose this is not related to my DAW.

    Ableton live 10
    Windows 10
    ESI M8Uex midi interface with multiclient driver.

    I’m also using MidiOX to get sync from my DAW knowing that selecting the option in the advanced settings of the MS2k editor make it crash.

    Hope you guys will find a fix soon, the bank manager being a major point to use the plugin

    Avatar
    w4too
    Participant
    Offline
    Registered On: July 22, 2019
    Topics: 1
    Replies: 7
    Has thanked: 1 time
    Been thanked: 0 times

    Hello again,

    I made a few tests and it appears that the Ms2K MIDI has compatibility problems with multiclient drivers (ESI M8U or RME Fireface 802) in Windows 10.
    I used the plug-in with my Midi UNO interface wich has no multiclient drivers and i could get individual patches on the library flawlessly knowing that the Global patch request still didn’t worked.
    I also made the test with MS2K patch buddy and made the same ascertainment. So it seems related to a hardware problem and the particularity of Windows with multiclient midi ports needing specific drivers.

    Problem for me is that i cannot get sync without MidiOX assuming the fact that the ports need to be multiclient to share access with Ableton Live, and selecting the Midi send clock in the Global settings of the plugin makes Live crash : the crash dump report is The thread attempted to divide an integer value by an integer divisor equal to zero.

    Hope this can help Jani to find a solution.

    Cheers

    Avatar
    w4too
    Participant
    Offline
    Registered On: July 22, 2019
    Topics: 1
    Replies: 7
    Has thanked: 1 time
    Been thanked: 0 times

    So it seems related to a hardware problem

    [edit]Spoke too fast. I installed the last multiclient drivers of my M-Audio interface and it appears that the patch request to the librarian works better, slowy, but with less timed out connections (the drivers are from 2010). If this could be of any help…

  • You must be logged in to reply to this topic.