Roland JP-80×0 Librarian Functions (Chapter 3)

User Manual Chapter 3 – Librarian Functions

for Roland JP-80×0 Editor & Librarian plug-in by Mystery Islands Music

v2.6.0 – 2020-03-17

Using the Librarian

With our built-in Patch / Performance Librarian, the user can manipulate banks as they like.  Drag’n’drop patches / performances from one bank to another, rename patches / performances and store the desired bank to the synthesizer’s memory or pull banks from memory to librarian.

This is quite an extensive guide, so we want to walk you through every step one by one while trying to write everything down in a most-common way. So, get some coffee or tea and let’s begin!

TIP #1: Always make sure that your performance or patch banks are not named such as: “this_is_the_ultimate_dance_and_trance_leads_mashup_bank_volume_2_of_5.mid”

I can tell you right now, that the plug-in and librarian is not going to like it and might even crash. Make sure to keep your patch names clean and simple. If you can not see the bank name extension in the librarian menu, revise the bank name to be less than 32 characters.

TIP #2: You can always create a set of sub folders in your Patches folder to organize your Banks better. See image below how I’ve organized my banks to keep them in tidy order. This way the Bank name does not exceed the suggested length.


Select Program with Double Click

Double clicking any item in the librarian program view, will send the slot data to the hardware temp memory. If you have Upper Layer selected in the plug-in user interface and you double click slot 12 while in Patch mode, then slot 12 data will be sent to JP’s upper layer!

This will also update the plug-in interface, so it is in sync with the data on your JP!


Select Program using Arrow keys from keyboard

You can also use Arrow keys from your computer keyboard to browse through different programs in the librarian view. Clicking arrow up while slot 11 is chosen, will choose slot 88 as a next slot. Using left arrow key while in slot 88, will choose slot 48 next and send it to hardware.

Note #1: this only works when you mouse cursor is on top of the left or right program view area.

Note #2: if you have chosen to browse in right program view, then program from right program view will be sent to hardware. Same applies to left program view too, so if you are browsing programs in that view, then the corresponding data will be sent to hardware.

Note #3: This will also update the plug-in user interface with the program values.


Different sections in Librarian User Interface

Left Patch / Performance program view

[1] This is the main “edit” area of your active bank. What ever you edit in the left bank view, can be stored later on. You can rename individual Patches / Performances, request data from hardware to the bank slots, Initialize Patches / Performances as you go and quickly get data from the plug-in user interface to the selected slot or store single data or whole bank to the hardware.

More details about the BANK EDIT functions and Right Click Menu functions below in this document.

NOTE #1 Once you start to manipulate the bank, DISCARD [1] button will appear between the bank names indicating that you’ve started your editing work.

NOTE #2 Once the Discard button appears, you can not change to different Librarian Mode [2] nor you can’t change to different bank with left Patch / Performance bank menu [3] until changes are saved or discarded.

NOTE #3 You can still use the right Patch / Performance bank menu [4] to browse other banks while the main edit area is locked! See details below.


Right Patch / Performance program view

[1] This is our “helping tool” bank view which allows you to view other bank contents while the main edit view is locked due to ongoing edits. You can copy selected slot Patch / Performance to clipboard and paste it on the main edit view. You can also drag’n’drop data from any slot to main edit view.

Learn more details about Copy & Paste and Drag’n’drop further below the document.


Previous & Next Bank buttons

You can quickly navigate to previous or next bank in the list by clicking the PREVIOUS [1] or NEXT [2] bank button.

Note #1 that both “views” have their own Previous / Next buttons.


Bank Select Menu

Clicking the Bank Name [1 / 2] opens up the popup menu which displays all the current Patch / Performance bank files based on your Librarian Mode selection. See details below the image.

NOTE #1 Bank Name [1] menu becomes inactive if bank has edits in it. Save changes or Discard edits in order to browse other banks in this area.


Librarian Mode / Operation Mode

LIBRARIAN MODE [1] button allows users to toggle between Performance / Patch files in librarian view. Performances contains Upper and Lower Patches, making it performance. You can also toggle the mode from the main user interface PATCH / PERFORMACE [2] button to toggle between the modes.


Search

Search can the toggled on by clicking the Magnifying Glass [1]Name Field [2] will popup allowing you to to enter your search criteria. Search results will appear in the Right Program View [3] if there are any.

NOTE #1 Search works based on character size. If the search term is less than 3 characters, search won’t give any results.


Store Data To menu

When you want to store your Patch / Performance bank from librarian to synthesizer memory, choose a target location of the data write from the Store Data To [1] dropdown menu. Data target location varies based on your current operating mode. This target location is only used when you want to write single Patch / Performance to hardware memory using the Bank Edit Menu function.


Request Data From menu

You can choose which bank will be requested the to librarian when the request command is triggered from the Bank Edit Menu. Choose request location by clicking REQ DATA FROM [1] dropdown menu.

Bank Edit menu functions are discussed further below.

Note #1 that JP-8000 incompatible banks are marked with ** as they only work with JP-8080. This is due to JP-8080’s internal memory + optional card memory, which makes it’s capacity bigger.


Request Interval

Set a desired REQUEST INTERVAL [1] for your request and write commands. Default is set to 200ms, but in some cases it might cause time out messages. If that is the case, then increase the Request Interval until requests succeed.

Note #1 When making requests to librarian, try not to interfere the MIDI flow by any means. This might cause unexpected results and could potentially freeze the plug-in until its forced to restart. Once the request process is ongoing, sit back for a few minutes 😎


Save Part to Slot

With SAVE PART TO SLOT [1] you can quickly get data from the plug-in user interface to the librarian. Data will be put to an active slot on main edit window. If right program display is chosen, this function will not be available. Once the data is in the chosen librarian slot, you can then save the bank, rename the patch / performance or discard your changes.


Sync Data From HW

SYNC DATA FROM HW [1] does what it says. This will get all of the temp performance and system data from the synthesizer to the plug-in user interface. Once you’ve set your MIDI in and MIDI out you are better off to start with Sync Data from HW before you start to work with the interface in the first place.

The reason is quite simple; we need to get the current hardware status to the plug-in user interface to address control changes and MIDI messages to the right layers etc.

Note #1 This function does not request any data to the librarian. Use the Bank Edit menu functions to request data from hardware to librarian.


Push Data to HW

PUSH DATA TO HW [1] works like Total Recall but in manual mode. This will send the entire Performance data to hardware and the System settings too.

This is useful when you open your project containing the plug-in but for some reason you’ve lost the MIDI interface along the way or if you open your project in another studio without the MIDI interface attached when you saved your work. You can choose different MIDI in and MIDI out and click Push Data to HW and you’ll get the sound in the JP, regardless of the place you are at.


Abort Process

ABORT PROCESS [1] button will briefly appear when you make requests from hardware to plug-in user interface or when you send Patches / Performances to the hardware. If something in the hardware settings isn’t right and / or the process takes too long, you can Abort the process and start from beginning manually.


Discard Changes

DISCARD [1] changes button will appear only when bank on the left-hand side has edits in it. This button will appear automatically, indicating that edit mode is “active”. You can discard any changes made to the bank if you are not happy with your bank edits.

NOTE #1 when button is visible, bank selection menu for the left data view is not accessible unless you save your changes or discard your edits.

Done! Now, take me to…

OR
Return to JP-80×0 User Manual Index

0
0
232
Rate this user guide

You are not allowed to rate this post.

If you found our guides helpful, please consider becoming a Patron on our Patreon page. This will help us to deliver more for you!